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2 Introduction 

2.1 Summary  
The scope of this cookbook is to provide an overview of how to effectively use the EMIR 
OSP. This document is intended to instruct users on how to effectively use the OSP without 
reading the full user manual. As a consequence it is not as detailed as some of the other 
OSP documentation. The aim here is to provide a simple overview and show useful 
examples of how to produce good results with the OSP.  

2.2 Conventions 
To indicate navigation within the OSP the following format is used: Project > Save. This 
should tell the user to click on the ‘Project’ menu and select ‘Save’.  

2.3 Acronyms 
 

2MASS Two Micron All Sky Survey 

CSU Configurable Slit Unit 

DRP Data Reduction Pipeline 

EMIR Espectrógrafo Multiobjeto Infrarrojo 

ESO European Southern Observatory 

FoV Field of View 

GTC Gran Telescopio CANARIAS 

HST Hubble Space Telescope 

OB Observing Block 

OSP Optimised Slit Positioner 

 
 

2.4 Installation Instructions 
The most recent stable version of the OSP can be accessed on the EMIR website:  
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http://www.iac.es/proyecto/emir/pages/observing-with-emir/observing-tools/osp.php 
 
To install the OSP download the current version from the EMIR webpage and move it to an 
appropriate location.  
 
Unpack the tar.gz file using (for example) the command: 

 
$ tar -zxvf EMIR-OSP-v<version>.tar.gz 

 
To run the OSP simply use the commands: 
 

$ cd OSP-v<version>/ 
$ ./osp.sh 

 
Please make sure that the osp.sh file is executable to run the final command (by default it 
should be).  
 

2.5 Acknowledgements 
2MASS etc.  

 

http://www.iac.es/proyecto/emir/pages/observing-with-emir/observing-tools/osp.php
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3 General Overview and Setup 

3.1 Overview 
The OSP takes as input an image of the region of interest as well as a catalogue, either user 
defined or using one of the available catalogue tools, and allows the user to allocate slitlets 
to targets in an optimised way. The result is then taken as input for the GTC to create the 
appropriate masks at the telescope. 
 
To use the EMIR OSP one must have two input files: 

1. A user input catalogue 
2. An image covering the field of view 

A template input catalogue can be found on the EMIR OSP web pages. The input image 
must be in the correct orientation (North up, East left) and contain no distortions. 
 
Once the targets have been selected and the user is happy with the results, three output 
files will be created: 

1. <name>.xml - a mask file containing relevant information on the mask, slits and 
allocated objects 

2. <name>.csu - the file required to configure and acquire the EMIR CSU 
3. <name>.conf - a summary file 

3.2 General strategy and notes 
To observe one EMIR MOS OB requires two masks. An acquisition mask where all slits have 
widths of 5” and a science mask where the width of the slits defines the resolution obtained.  
 
For an accurate and efficient acquisition, the two masks should be identical apart from the 
width of the slit. The reference objects defined in the acquisition mask will be used to acquire 
the field (see Section XX for more details on reference objects).  
 
Given the iterative nature of the procedure that you are about to undertake, we recommend 
that the first pass at using the OSP should be thought of as a “scratch” session.  In this 
version one can move the mask, iterate on objects to include, etc. Once a final mask position 
has been settled upon, open an additional OSP window to be used for the final version 
(using a new terminal and the osp.sh script once more). The second window can be thought 
of as the “final” version where the final task is to manually copy exactly the configuration 
from the “scratch” version. 
 

http://www.iac.es/proyecto/emir/media/OSP/EMIR-OSP-catalogue-template.dat
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The following sections are meant to be read roughly in order that they will be required in the 
OSP and will detail the various steps that the user needs to take to create an observable 
mask. It is assumed that one will have an OSP window ready.  
 
Notes: 

● A step-by-step example with images is detailed in Annex A.  
 

● The Overview Display panel (to the left of the Image Display) should never be used 
to navigate. The yellow box may appear tempting, but it will result in the Image 
Display panel snapping back to its original position each time the mouse click is 
used. Instead navigate by dragging the image in the Image Display panel. Not only 
will this be frustrating for the user, it will also result in an incorrect result. In summary, 
never use the Overview Display Panel. 
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4 Using the OSP 

4.1 New Project and workspace 
To start with the OSP select a directory for a new project either by using the drop down 
menu  Project > New or by using the New Project icon. A good choice is a directory that 
contains the background image and user catalogue, or where these files are easily 
navigated to. 
 

4.2 Background Images 
A background image is required to use the OSP. There are two options for doing so: 
 

● A local fits file (recommended) 
● The online image server 

 

4.2.1 Local fits file 
To load a local fits file navigate to Image > Load from > Local file 
 
This fits file must have an orientation North up and 
East to the left, as shown.  
 
There is no check for orientation upon loading the fits file 
to the OSP, therefore the user must ensure that any 
mask configuration created using a local file must 
conform to this standard. The OSP will display the 
orientation of the image in the Overview Display Panel, 
this should be checked. 
 
In addition to the specific orientation, any fits file that is 
loaded into the OSP must be corrected for any 
distortions. The OSP will not take into account distortions 
specified in the fits headers and this could result in the 
targets from an input catalogue being slightly out of place, particularly at the edges of the 
image.  
 
A good choice for a stable background image with the correct orientation and no distortions 
is from the 2MASS image server which can be accessed here. The largest 2MASS size 
image is an appropriate choice for the FoV of EMIR.  
 

https://irsa.ipac.caltech.edu/applications/2MASS/IM/interactive.html
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4.2.2 Image server 
Make a simple query to one of the image databases in the app via the Image > Load from > 
Server  (e.g. Digitized Sky (Version II) at ESO). The 2MASS image database via the 
2MASS website is also a useful alternative (see 4.2.1). 
 
Note: Please note that although DSS and 2MASS images can be used effectively, DSS and 
2MASS astrometry is not sufficient for the MOS allocation. Gaia astrometry has been shown 
to work well. Use an underlying 2MASS/DSS image and load a user defined catalogue with 
Gaia astrometry.  
 

4.3 Adding Objects 
In order to assign targets to slits one must add objects, there are three ways in which to do 
this: 
 

● Local Catalogue (highly recommended)  
● Manually 
● Online Catalogue 

 
The preparation of a local catalogue is highly recommended as the user defines the 
astrometry of the sources, the accuracy of which is of fundamental importance to EMIR MOS 
observations. In practice, a well defined catalogue of sources and reference stars with 
consistent astrometry makes the whole process of configuring a mask much easier. 
 

4.3.1 Local catalogue 
As mentioned above a well defined local catalogue is an important part of the mask 
generation process. The input catalogue must be in a specific format separated by spaces. 
The required and optional entries are detailed below: 
 
 

Required Fields Description 

Source ID  Name of source containing no spaces 

RA Right ascension of the source. hms format separated by 
colons (e.g. HH:MM:SS.XXX) 

DEC Declination of the source. dms format separated by colons 
(e.g. DD:MM:SS.XX) 
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Optional Fields Description 

Priority Priority of the target (integer either 1/2/3) 

Mag1 Apparent magnitude of the source in a particular band 

Mag2 Apparent magnitude of the source in a particular band 

Comment Any other comments separated by spaces 

 
 
The optional fields will be displayed and propagated by the OSP but not used in any way.  If 
the optional fields are not filled in, these columns will simply not be displayed and all 
priorities will be set to zero. Other priorities may be used in the catalogues, however, they 
will not be used. 
 
The input catalogue template and examples are listed on the main OSP pages. Please 
download the template catalogue and edit it to include the sources of interest.  
 
An example of a user input catalogue is shown below. In this example, the Jmag, Kmag, Pri. 
and Comment columns will be displayed in the OSP.  
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The first object in an input file should be the centre of the field and not used to allocate to a 
slit. The OSP makes no check for this, so users must be aware and not use this ‘object’ in 
their configuration.  
 
To load a local catalogue navigate to: Object > Add Objects > From local file. Once the 
catalogue has been added, all entries will appear as blue squares in the Image Display 
panel, in addition information on the sources will be displayed in the Catalogue Display panel 
including any optional columns.  
 
A note on astrometry: Consistent, precise astrometry is vital to the success of the EMIR 
mask configuration. HST and Gaia (others will appear here when tested) astrometry has 
been shown to work well. DSS, 2MASS astrometry are examples of astrometry which has 
been shown to not be sufficient for MOS allocation.  
 
A combination of Gaia and HST astrometry (in the same mask) has been shown to work 
well, however, it is recommended that the astrometry of all of the objects originate from one 
catalogue.  

4.3.2 Adding objects manually 
To add objects directly from the background image (in the astrometic solution of the 
background image) one navigates to Object > Add Objects > Manually 
The Add Objects window will now appear which displays statistics and information on the 
added object. 

 
 



EMIR-OSP Cookbook 12 
 
 

To add an object manually, one simply clicks on the background image where an object is 
present, statistics will be displayed in the Add Objects window. Repeat this process for each 
target then Close the Add Objects window. This will add all of the objects that have been 
selected using clicks to the catalogue display.  
 
If no object is detected and the centroid routines cannot accurately calculate the position, the 
coordinates of the click position will be used to define the object.  
 
Tip: Zooming in using the + button on the image display window allows for a more accurate 
click position. 
 
Note: Adding objects manually requires the astrometry of the image to be precise and 
absolute. One should exercise caution before adding objects manually when a Local 
catalogue has been used as the astrometric solution of the image may not be identical 
to that of the sources in the catalogue.  

4.4 Adding the mask 
To assign objects to slits one first needs to add a mask. To add a mask to the current 
configuration navigate to Mask > New mask on current image  
 
The mask can be moved and rotated using the Move Mask and Rotate Mask buttons 
(image below) or by using the Selected Mask Properties box. 

 
 
 
Once a mask has been added there are two methods by which to assign objects: 
 

● Manually (recommended) 
● The Search Facility 

 
The manual assignment of slits is recommended as it gives users full control over where in 
the slits objects are placed. The Search button can be used to obtain an initial estimate of 
the mask configuration, the manual assignment can then be used to define the final 
configuration. 
 
If, after you assign an object to a slit, you would like to change its position, you must first 
reset the current slit by navigating to Slit > Reset Selected Slit. Once the slit has been 
reset, then you may reassign the slit to another object/position. Respecting this order is 
particularly important for Reference objects as a memory issue can cause problems with the 
acquisition of the mask at the telescope, this is one of the reasons we recommend using 
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“scratch” and “final” OSP sessions (see Section 5.7.1 and Annex A for details). Masks that 
contain objects not assigned to slits will be rejected (See Section 6). 
 
The slit position defined in the OSP will determine the wavelength coverage of the observed 
spectra. The further away from the central position, the more the nominal wavelength 
coverage will change. To check the wavelength coverage of a mask the EMIR DRP provides 
a routine to do this. Instructions on how to do this are provided in Annex B. 
 
Note: Slit #1 and #55 are not visible on the EMIR detector. Targets in these slits will 
not be observed. The OSP does not take this into account.  
 

4.4.1 Manually assign objects to slits 
Manually assigning objects to slits is the recommended procedure for producing a good 
mask. This gives the user the most control of where along the spatial direction of the slit the 
target is place (the Search Facility does no such checking).  
 
To manually assign an object to a slit, right click on the object in question and select assign 
to slit. This results in the highlighted object being associated with its nearest slit. The 
position and width of the slit can be viewed in the Selected Slit Properties box (when the 
slit in question is highlighted green in the Image Display panel). 
 
The slit width can be set in the Selected Slit Properties window or the default slit width (to 
be used for all allocated slits) can be set by navigating to Slit > Set default aperture.  
 
If the user moves or rotates the mask, this process of object allocation must be repeated. In 
addition, if the position of the slit is changed without using the Reset Selected Slit option, 
the slit in question will continue to be associated with the object, which is likely not intended.  
 

4.4.2 The search facility 
The Search Facility allows one to search a variety of different positions to maximise the 
number of objects allocated to slits. The function is a useful starting point for creating a 
mask. Remember that users can edit the result of the search but if one moves or rotates the 
mask, all objects must be re-assigned (by hand). 
 
Currently this function does not account for the position of the object in the slits, which is an 
important consideration when deciding the offset throw for the observations. In this respect 
the Search Facility also cannot allocate multiple slits to an object. This must be done by 
hand.  
  
When saving a mask using the search facility, make sure that the mask you are currently 
viewing in the OSP is the mask you would like to save. 
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Tip: When saving the project, it is useful to delete unwanted masks by simply highlighting 
them in the Field of View panel (left hand side) and tapping “Delete” on the keyboard. 
 
Note: The limit of the CSU in the borders is +/-110” from the central position. The 
Search Facility does not respect this limit. If objects are allocated beyond this limit, 
there will likely be problems either in writing the masks or at the telescope.  

4.4.3 Managing the slits 
It is currently advised to create a slitlet using a two or more slits, i.e. one slit for the A 
position, one slit for the B position. This can be achieved by first highlighting the slit that shall 
be joined and navigating to Slit > Join slits. An example is shown below where each target 
is allocated at least three slits. A longer slit is used to avoid a bright object in the central 
position.  

 
If the target density is such that you would like to assign only one slit to an object, care must 
be taken in order to calculate the ABBA sky offset. Each slit is ~7.2”. 
 
To set the width of the slit use the Selected Slit Properties box or globally set the width of 
the slits use the Slit > Set default aperture (this is particularly useful when defining the 
acquisition mask).  
 
Note: Slits 1 and 55 do not fall fully on the detector. Use of these slits must be made 
with care, specifically, one may not allocate a reference object in slit #54 and create a 
joined slit with #55. This however, may be done with targets that are not reference 
objects.  
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4.5 Reference Objects 
Reference objects are used at the telescope to acquire the field. For a good acquisition, 
references targets should be isolated, bright and have similar brightness (i.e. small range 
of magnitudes). Each mask must contain at least 3 reference objects, but in general, the 
more well defined reference targets the better. In this context “bright” refers to point sources 
in the range 9-17 in the filter considered. Table 5.5.1 summarises the required properties 
that reference stars must have in each mask. 
 
Reference objects are treated exactly the same as science objects and as such one may 
use science objects as reference.  
 
It is advised to assign the same number of slits to a reference star as to a science object. 
This makes the quality control checking easier when reducing the data. 
 
The reference stars (and reference stars alone) will be used to acquire the field. Therefore, 
the astrometry of these stars is vital. Please ensure precise, consistent astrometry for both 
reference and science objects. 

Table 4.5.1: Overview of the required properties of reference stars 
 

Property Criteria 

Number At least 3 in each mask, but the more the better* 

Magnitude 9-17 (in the band of observation) 

Isolation No surrounding stars of similar magnitudes within the 
5” slit 

 
*Reference objects must be the brightest object within a 5” slit 
 
If you find that you are not able to find reference stars that meet the criteria in Table 5.5.1, 
there exists an additional mode of acquisition specifically do deal with fainter targets. In this 
mode an ABBA image will be observed with the mask configuration in place and the 
observations will be reduced on-the-fly to identify faint reference targets.  
 
The drawback of this method is that it requires more observing time than the previous, 
however, this does allow one to use fainter reference targets than normally allowed.  
 
The two methods described in this section are the most efficient mode of acquisition. In 
addition, including reference stars in the observed mask allows one to check the centring of 
the mask and maintain quality control checks on the OB. For these reasons we recommend 
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the two above methods of acquisition. A blind offset in MOS mode is of course possible, but 
in practice almost never requested. 

4.6 Validate mask and Save 

4.6.1 Validate and write the mask 
To create the CSU input file we must first Validate and Write the mask. First reset the zoom 
to 1:1, then click the Validate button. The validation process checks the number of reference 
stars in the mask. Once the mask has been correctly validated, a pop-up window allows the 
user to Write the mask by clicking the appropriate button on the pop-up window.  
 
After writing the mask, three files will be written: 
 

● <name>.csu 
● <name>.xml 
● <name>.conf 

 
The .csu file is the mask configuration file that must be passed to the GTC during Phase II. 
This file contains information on the position of each bar and must not be edited by hand.  
 
The .xml file created at this stage contains the information on the mask that has been 
written. This includes the catalogue entry for each target, as well as information on the 
position (in arcseconds) of each slit.  
 
The .conf file contains relevant information on what targets have been assigned slits as well 
as their catalogue entries in a simple format. This file is useful to keep track of the targets 
that have been assigned to which slit when coming to reduce the data. 
 

4.6.2 Save the project 
The entire project is saved by navigating to Project > Save selecting a different name to that 
of the mask XML file (e.g.<name>_p.xml). The project XML file can be used to reopen the 
whole project at a later date and make changes. This project file may contain several 
different mask.  
 
Note: If one does not Save the project xml file, the mask cannot be reopened at a later 
date.  

4.7 General notes 
This section contains some general notes and tips, that do not fit in the previous sections, to 
produce good output files from the OSP.  
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● In order to acquire the field accurately, a slit width of 5” is recommended 
● The user should create two XML files (and corresponding CSU files), one with the 

acquisition aperture (5”) and a second with the appropriate aperture for the science 
observations. This file should have the same name as the acquisition file but start 
with “fine_” e.g. 

○ fine_Patrick-2018-05-08-NGC6822.xml 
○ Patrick-2018-05-08-NGC6822.xml 

4.7.1 Best use of the OSP 
The quickest way to produce a useful configuration file from the OSP is to use a “scratch” 
session and a “final” session.  
 

1. Use one OSP window as a “scratch” session and complete the above steps 
2. Define and check the required slit positions and wavelength coverage (see Annex B) 
3. Once the final configuration has been decided upon, open a new OSP and copy this 

pattern from the “scratch” OSP manually 
 
Once all targets have been appropriately allocated to their slits in a clean OSP window, 
validate the mask and save the project. To do this, first make sure that the zoom has been 
reset by selecting 1:1 in the Overview Display. Once the zoom has been reset, select the 
Validate option. Validating the mask simply checks the number of reference targets within 
the catalogue. If you do not have enough reference targets assigned, add more by right click 
then navigating to Is reference. (Or close the warning message and Validate once more.)  
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5 Checking the OSP result 
An external tool exists to perform some sanity checks on the files generated from the OSP 
and provide a summary file that can be used to monitor the observation. This script is 
distributed with the OSP and can also be downloaded from the OSP main pages. 

5.1 Use of the EMIR OSP facility tool 
This script takes as input one or two of the three files produced by the OSP. Below is an 
example of its use: 
 

$ python3 OSP2CSUv7.py <name> 
 

Or:  
$ python3 OSP2CSUv7.py <name>.xml <name>.csu 
 

Where <name> contains the full path and filename of the xml and csu files. The script 
outputs a summary to the screen: 
 

$ python3 OSP2CSUv7.py <name> -5.0 
10h11m05.138s -4d42m00.0071s 0.0 
UUID:  e390356b-1666-4160-bd1e-ca486915f1fc 
    Object: 10:11:08.487 -04:40:46.65 
   Coord. estandar: 50.067   73.357 
    1401.651  767.087 
    Object: 10:11:01.950 -04:42:32.73 
   Coord. estandar:   -47.659  -32.723 
     856.259 1269.529 
    Object: 10:10:53.812 -04:41:07.28 
   Coord. estandar:  -169.322   52.721 
    1295.558 1895.042 

 
 
Where the output details the full list of assigned objects in the mask. This script will only 
work on assigned objects, objects in slits that have been positioned by hand (or adjusted by 
hand) will either not be displayed, or be displayed incorrectly. Then, two new files are written 
in the same directory as the XML and CSU files: 

● <name>.summary : a summary of the configuration 
● <name>.png : an image of the CSU file 

The png file  (see the below figure), is a very useful diagnostic of how the mask will perform 
at the GTC. The png file shows how the mask will be seen by the EMIR detector. The target 
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objects are plotted as blue crosses and the reference objects, as red ones. The red arrow, if 
present, at the middle left shows the direction in which the objects will move from A to B in 
the telescope nodding ABBA sequence. Be aware that it shows the motion of the objects, 
not that of the telescope, in the EMIR focal plane when nodding. In the title and subtitle, the 
mask name and mask id are printed. Users must inspect this figure carefully looking for 
flaws. For instance, in the below figure some of the objects will be lost when the telescope 
nods to the second pointing, and the objects will move in the detector following the arrow, as 
the nod throw is 7.2 arcsecs, or one full slit height. 

5.2 Identifying bad masks and what to do about it 
A mask that has been well defined, typically, will have an object assigned to each slit. In the 
.png file that is created from the OSP2CSU script this will look like Fig 1.  
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A common error when generating creating a mask in the OSP is when one assigns an object 
then moves the mask in some way. In Fig 1., this causes crosses to appear out of position or 
will cause the magenta circle to be slightly displaced. If this is the case, one needs to redo 
the mask completely, preferably by opening a new OSP window and copying the progress 
from the previously defined mask. 
 
Tip: Open an OSP window (using the osp.sh script) for use as a scratch version. See 
Section 4.7.1 for more details.  
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6 Disclaimer 
There are of course many different ways to make good use of the EMIR OSP. This 
document consists some suggestions to make the process easier. If any of the information in 
this document is found to be inaccurate or out of date, please let me know via email on 
lpatrick@iac.es.  

 

mailto:lpatrick@iac.es
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Annex A: Simple Working Example 
This section provides step-by-step instructions on how to create a basic mask that can be 
effectively observed at the telescope.  
 
In the following we assume that the user already has the two crucial items for mask 
generation:  

● A catalogue of sources including reference objects 
● An appropriate image covering the field of view 

 
These instructions are applicable for OSP version 2.6.8 and higher. 

Step-by-step Guide 
1. Start by creating a new project: Project > new and select the directory that will be 

used to save the output. 
2. Now load the base image Image > Load From > Local File. Where OSP-test was 

the directory selected in step 1. 
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One can change the cut levels using the Image > Edit Cut levels box and double 
clicking on one of the preset levels.  
 

3. Now load a catalogue.  Navigate to: Object > Add Objects > From local file and 
select your catalogue, in the specified format. An example can be downloaded from 
the OSP main pages.  
 
The OSP should now look something like the below image, where the blue squares 
are all of the targets in the catalogue.  

 
 
 

4. Add a mask. Once we have successfully loaded both the image and catalogue we 
now define the mask. To do this navigate to Mask > New mask on current image 
 
Move the mask to the desired position using the Move Mask and Rotate Mask 
buttons or the Selected Mask Properties box by inserting a value and hitting return. 
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5. Designate Reference targets. See Section 5.5 for more information on what makes a 
good reference target. Designating reference targets can be done by right clicking on 
target and select the is Reference option, as shown in the below image. 

 
 

By right clicking on a target in the Image Display panel, the target selected is 
highlighted in green in the Catalogue Display panel. Once a target is designated a 
reference object, two things will change: 1. The target in question will be depicted as 
a red cross in the Image Display panel and 2. In the Catalogue Display Panel, a tick 
will appear in the IsRef box. 
 

6. Assign targets to slits. Once the reference objects have been defined assign the 
targets to available slits. This step may take several iterations depending on how 
many targets one would like to assign.  
 
Targets are assigned to slits by right clicking on target > assign to slit. This option 
can be seen in the above figure. At this stage the main points to consider are:  

● How many slits to use for a single target? 
● What is the offset-to-sky required? 
● What is the best position so that as many objects as possible are well centred 

in both the A and B positions? 
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● How many objects go into a single mask? 
● What is the best mask angle/position to use? 

 
7. In practice, step #6 will be the most time consuming and will likely involve many 

iterations and mask movements. Because of this we recommend the following. Use 
one OSP window as a scratch version. In this version one can move the mask, iterate 
on objects to include etc. Once a final mask position has been settled upon, open an 
additional OSP window to be used for the final version (using a new terminal and 
osp.sh script). With the final version manually copy exactly the setup from the scratch 
version. One should have the following picture:  
 

 
Two seemingly identical versions of the OSP mask where the left is the scratch 
where many iterations have been made and the right is the final version, where the 
final mask will be copied and no iterations will be made.  
 

8. Validate and Save. When you are happy with your mask we can now Validate and 
write the configuration. This will write three files: <name>.xml, <name>.csu, 
<name>.conf. Keep file names simple: ‘PI-date-fieldname.xml’. Now also Navigate to 
Project > Save as and save the project file as <name>_p.xml. This is the file that will 
allow you to load your mask in a new session 
 

9. Check the OSP result. This can be done using the OSP2CSU.py script and is 
detailed in Section 6. If there are any discrepancies, the user must identify why and 
redo these steps.  
 

10. Congratulate yourself on a job well done! 
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Annex B: Wavelength Coverage of Slits 
This section describes the process of how one can estimate the wavelength coverage of the 
EMIR OSP mask. This is important to check as the position of the slit with respect to the 
nominal position defines the wavelength coverage and if a user is interested in a particular 
feature at a particular wavelength, it is imperative to know if this will be covered by the mask.  
 
The EMIR DRP documentation provides installation instructions, the notes in this section 
assume that one has correctly installed the EMIR DRP.  
 
And after installing the DPR the pyemir-display_slitlet_arrangement routine can 
be used to estimate the wavelength coverage for a particular filter for a given mask.  
 
Step by step instructions on how to estimate the wavelength coverage of your mask: 
 
 

1. Copy the .csu file, which has been produced by the OSP, and change the extension 
to .txt. 
 

2. Activate your python environment using the following command: 
 
$ source activate emir 
 

3. Run the pyemir-display_slitlet_arrangement routine: 
 
$ pyemir-display_slitlet_arrangement  mask3_CSU.txt 

--grism LR  --filter HK 
 

The output to the terminal should look like this:  
 

File 1/1: mask_dic2018_06_CSU.txt 
slit  left right   center   width   min.wave   max.wave 
====  =======  =======  =======   =====   ========   ======== 
   1  105.390  106.940  106.165   1.550   15675.03   24300.00 
   2  105.330  106.780  106.055   1.450   15679.65   24300.00 
… 
  54  169.700  170.710  170.205   1.010   14500.00   24300.00 
  55  169.690  170.620  170.155   0.930   14500.00   24300.00 
 

Where the final two columns define the minimum and maximum wavelength achieved 
on the detector 
 
The options for the --grism parameter are: J, H, K, LR 

https://pyemir.readthedocs.io/en/latest/user/index.html
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The options for the --filter parameter are: J, H, K, YJ, HK  
 
 


